upstream V3 development https://www.gnusocial.rocks/v3
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

230 lines
7.6 KiB

  1. {
  2. "type": "project",
  3. "name": "gnu/social",
  4. "description": "Free software social networking platform.",
  5. "license": "AGPL-3.0-only",
  6. "require": {
  7. "php": "^8.1",
  8. "ext-ctype": "*",
  9. "ext-curl": "*",
  10. "ext-iconv": "*",
  11. "ext-openssl": "*",
  12. "composer/package-versions-deprecated": "1.11.*",
  13. "doctrine/annotations": "^1.0",
  14. "doctrine/doctrine-bundle": "^2.4",
  15. "doctrine/doctrine-migrations-bundle": "^3.1",
  16. "doctrine/orm": "^2.9",
  17. "erusev/parsedown": "^1.7",
  18. "knplabs/knp-time-bundle": "^1.17",
  19. "lstrojny/functional-php": "^1.17",
  20. "nyholm/psr7": "^1.4",
  21. "odolbeau/phone-number-bundle": "^3.1",
  22. "oro/doctrine-extensions": "^2.0",
  23. "php-ds/php-ds": "^1.2",
  24. "phpdocumentor/reflection-docblock": "^5.2",
  25. "sensio/framework-extra-bundle": "6.*",
  26. "someonewithpc/memcached-polyfill": "^1.0",
  27. "someonewithpc/redis-polyfill": "dev-master",
  28. "symfony/asset": "5.4.*",
  29. "symfony/cache": "5.4.*",
  30. "symfony/config": "5.4.*",
  31. "symfony/console": "5.4.*",
  32. "symfony/dom-crawler": "5.4.*",
  33. "symfony/dotenv": "5.4.*",
  34. "symfony/event-dispatcher": "5.4.*",
  35. "symfony/expression-language": "5.4.*",
  36. "symfony/filesystem": "5.4.*",
  37. "symfony/flex": "^1.3.1",
  38. "symfony/form": "5.4.*",
  39. "symfony/framework-bundle": "5.4.*",
  40. "symfony/http-client": "5.4.*",
  41. "symfony/intl": "5.4.*",
  42. "symfony/mailer": "5.4.*",
  43. "symfony/messenger": "5.4.*",
  44. "symfony/mime": "5.4.*",
  45. "symfony/monolog-bundle": "^3.1",
  46. "symfony/notifier": "5.4.*",
  47. "symfony/process": "5.4.*",
  48. "symfony/property-access": "5.4.*",
  49. "symfony/property-info": "5.4.*",
  50. "symfony/proxy-manager-bridge": "5.4.*",
  51. "symfony/security-bundle": "5.4.*",
  52. "symfony/serializer": "5.4.*",
  53. "symfony/string": "5.4.*",
  54. "symfony/translation": "5.4.*",
  55. "symfony/twig-bundle": "5.4.*",
  56. "symfony/validator": "5.4.*",
  57. "symfony/var-exporter": "5.4.*",
  58. "symfony/web-link": "5.4.*",
  59. "symfony/yaml": "5.4.*",
  60. "symfonycasts/reset-password-bundle": "^1.9",
  61. "symfonycasts/verify-email-bundle": "^1.0",
  62. "tgalopin/html-sanitizer-bundle": "^1.2",
  63. "theofidry/psysh-bundle": "^4.4",
  64. "twig/extra-bundle": "^2.12|^3.0",
  65. "twig/markdown-extra": "^3.0",
  66. "twig/twig": "^2.12|^3.0",
  67. "wikimedia/composer-merge-plugin": "^2.0"
  68. },
  69. "require-dev": {
  70. "codeception/codeception": "^4.1",
  71. "codeception/module-phpbrowser": "^2.0",
  72. "codeception/module-symfony": "^2.1",
  73. "doctrine/doctrine-fixtures-bundle": "^3.4",
  74. "friendsofphp/php-cs-fixer": "^3.2.1",
  75. "jchook/phpunit-assert-throws": "^1.0",
  76. "niels-de-blaauw/php-doc-check": "^0.2.2",
  77. "phpstan/phpstan": "dev-master",
  78. "phpunit/phpunit": "^9.5",
  79. "symfony/browser-kit": "^5.4.",
  80. "symfony/css-selector": "^5.4.",
  81. "symfony/debug-bundle": "^5.4.",
  82. "symfony/error-handler": "^5.4.",
  83. "symfony/maker-bundle": "^1.14",
  84. "symfony/phpunit-bridge": "^5.4.",
  85. "symfony/stopwatch": "5.4.*",
  86. "symfony/web-profiler-bundle": "^5.4.",
  87. "ulrichsg/getopt-php": "*",
  88. "wp-cli/php-cli-tools": "^0.11.13",
  89. "codeception/module-asserts": "^1.0.0"
  90. },
  91. "config": {
  92. "preferred-install": {
  93. "*": "dist"
  94. },
  95. "sort-packages": true,
  96. "allow-plugins": {
  97. "composer/package-versions-deprecated": true,
  98. "symfony/flex": true,
  99. "wikimedia/composer-merge-plugin": true
  100. }
  101. },
  102. "autoload": {
  103. "files": [
  104. "src/Core/I18n/I18n.php"
  105. ],
  106. "psr-4": {
  107. "App\\": "src/",
  108. "Plugin\\": "plugins/",
  109. "Component\\": "components/"
  110. }
  111. },
  112. "autoload-dev": {
  113. "psr-4": {
  114. "App\\Tests\\": "tests/"
  115. }
  116. },
  117. "replace": {
  118. "paragonie/random_compat": "2.*",
  119. "symfony/polyfill-ctype": "*",
  120. "symfony/polyfill-iconv": "*",
  121. "symfony/polyfill-php72": "*",
  122. "symfony/polyfill-php71": "*",
  123. "symfony/polyfill-php70": "*",
  124. "symfony/polyfill-php56": "*"
  125. },
  126. "scripts": {
  127. "auto-scripts": {
  128. "cache:clear": "symfony-cmd",
  129. "assets:install %PUBLIC_DIR%": "symfony-cmd"
  130. },
  131. "post-install-cmd": [
  132. "@auto-scripts",
  133. "cp -fu bin/pre-commit .git/hooks"
  134. ],
  135. "post-update-cmd": [
  136. "@auto-scripts"
  137. ]
  138. },
  139. "conflict": {
  140. "symfony/symfony": "*"
  141. },
  142. "extra": {
  143. "symfony": {
  144. "allow-contrib": false,
  145. "require": "5.4.*"
  146. },
  147. "merge-plugin": {
  148. "include": [
  149. "components/*/composer.json",
  150. "plugins/*/composer.json"
  151. ]
  152. }
  153. },
  154. "repositories": [
  155. {
  156. "type": "package",
  157. "package": {
  158. "name": "niels-de-blaauw/php-doc-check",
  159. "version": "0.2.2",
  160. "bin": [
  161. "bin/php-doc-check"
  162. ],
  163. "autoload": {
  164. "psr-4": {
  165. "NdB\\PhpDocCheck\\": "src"
  166. }
  167. },
  168. "source": {
  169. "url": "https://github.com/someonewithpc/php-doc-check.git",
  170. "type": "git",
  171. "reference": "master"
  172. }
  173. }
  174. },
  175. {
  176. "type": "package",
  177. "package": {
  178. "name": "ulrichsg/getopt-php",
  179. "version": "4.0.0",
  180. "autoload": {
  181. "psr-4": {
  182. "GetOpt\\": "src"
  183. }
  184. },
  185. "source": {
  186. "url": "https://github.com/someonewithpc/getopt-php.git",
  187. "type": "git",
  188. "reference": "master"
  189. }
  190. }
  191. },
  192. {
  193. "type": "package",
  194. "package": {
  195. "name": "codeception/codeception",
  196. "version": "4.1.30",
  197. "autoload": {
  198. "psr-4": {
  199. "Codeception\\": "src/Codeception",
  200. "Codeception\\Extension\\": "ext"
  201. },
  202. "files": ["functions.php"]
  203. },
  204. "require": {
  205. "php": ">=5.6.0 <9.0",
  206. "ext-curl": "*",
  207. "ext-json": "*",
  208. "ext-mbstring": "*",
  209. "codeception/lib-asserts": "^1.0 | 2.0.*@dev",
  210. "guzzlehttp/psr7": "^1.4 | ^2.0",
  211. "symfony/finder": ">=2.7 <6.0",
  212. "symfony/console": ">=2.7 <6.0",
  213. "symfony/event-dispatcher": ">=2.7 <6.0",
  214. "symfony/yaml": ">=2.7 <6.0",
  215. "symfony/css-selector": ">=2.7 <6.0",
  216. "behat/gherkin": "^4.4.0",
  217. "codeception/phpunit-wrapper": ">6.0.15 <6.1.0 | ^6.6.1 | ^7.7.1 | ^8.1.1 | ^9.0",
  218. "codeception/stub": "^2.0 | ^3.0 | ^4.0"
  219. },
  220. "bin":["codecept"],
  221. "source": {
  222. "url": "https://github.com/someonewithpc/Codeception.git",
  223. "type": "git",
  224. "reference": "4.1"
  225. }
  226. }
  227. }
  228. ]
  229. }