upstream V3 development https://www.gnusocial.rocks/v3
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

235 lines
6.5 KiB

  1. {
  2. "type": "project",
  3. "name": "gnu/social",
  4. "description": "Free software social networking platform.",
  5. "license": "AGPL-3.0-only",
  6. "require": {
  7. "php": "^8.1",
  8. "ext-ctype": "*",
  9. "ext-curl": "*",
  10. "ext-iconv": "*",
  11. "ext-openssl": "*",
  12. "composer/package-versions-deprecated": "1.11.*",
  13. "doctrine/annotations": "^1.0",
  14. "doctrine/doctrine-bundle": "^2.4",
  15. "doctrine/doctrine-migrations-bundle": "^3.1",
  16. "doctrine/orm": "^2.9",
  17. "erusev/parsedown": "^1.7",
  18. "knplabs/knp-time-bundle": "^1.17",
  19. "lstrojny/functional-php": "^1.17",
  20. "masterminds/html5": "^2.7",
  21. "mf2/mf2": "^0.4.6",
  22. "odolbeau/phone-number-bundle": "^3.1",
  23. "oro/doctrine-extensions": "^2.0",
  24. "php-ds/php-ds": "^1.2",
  25. "phpdocumentor/reflection-docblock": "^5.2",
  26. "sensio/framework-extra-bundle": "^5.5",
  27. "someonewithpc/memcached-polyfill": "^1.0",
  28. "someonewithpc/redis-polyfill": "dev-master",
  29. "symfony/asset": "5.4.*",
  30. "symfony/cache": "5.4.*",
  31. "symfony/config": "5.4.*",
  32. "symfony/console": "5.4.*",
  33. "symfony/dom-crawler": "5.4.*",
  34. "symfony/dotenv": "5.4.*",
  35. "symfony/event-dispatcher": "5.4.*",
  36. "symfony/expression-language": "5.4.*",
  37. "symfony/filesystem": "5.4.*",
  38. "symfony/flex": "^1.3.1",
  39. "symfony/form": "5.4.*",
  40. "symfony/framework-bundle": "5.4.*",
  41. "symfony/http-client": "5.4.*",
  42. "symfony/intl": "5.4.*",
  43. "symfony/mailer": "5.4.*",
  44. "symfony/messenger": "5.4.*",
  45. "symfony/mime": "5.4.*",
  46. "symfony/monolog-bundle": "^3.1",
  47. "symfony/notifier": "5.4.*",
  48. "symfony/process": "5.4.*",
  49. "symfony/property-access": "5.4.*",
  50. "symfony/property-info": "5.4.*",
  51. "symfony/proxy-manager-bridge": "5.4.*",
  52. "symfony/security-bundle": "5.4.*",
  53. "symfony/serializer": "5.4.*",
  54. "symfony/string": "5.4.*",
  55. "symfony/translation": "5.4.*",
  56. "symfony/twig-bundle": "5.4.*",
  57. "symfony/validator": "5.4.*",
  58. "symfony/var-exporter": "5.4.*",
  59. "symfony/web-link": "5.4.*",
  60. "symfony/yaml": "5.4.*",
  61. "symfonycasts/reset-password-bundle": "^1.9",
  62. "symfonycasts/verify-email-bundle": "^1.0",
  63. "tgalopin/html-sanitizer-bundle": "^1.2",
  64. "theofidry/psysh-bundle": "^4.4",
  65. "twig/extra-bundle": "^2.12|^3.0",
  66. "twig/markdown-extra": "^3.0",
  67. "twig/twig": "^2.12|^3.0",
  68. "wikimedia/composer-merge-plugin": "^2.0"
  69. },
  70. "require-dev": {
  71. "codeception/codeception": "^4.1",
  72. "codeception/module-phpbrowser": "^2.0",
  73. "codeception/module-symfony": "^2.1",
  74. "doctrine/doctrine-fixtures-bundle": "^3.4",
  75. "friendsofphp/php-cs-fixer": "^3.2.1",
  76. "jchook/phpunit-assert-throws": "^1.0",
  77. "niels-de-blaauw/php-doc-check": "^0.2.2",
  78. "phpstan/phpstan": "dev-master",
  79. "phpunit/phpunit": "^9.5",
  80. "symfony/browser-kit": "^5.4.",
  81. "symfony/css-selector": "^5.4.",
  82. "symfony/debug-bundle": "^5.4.",
  83. "symfony/error-handler": "^5.4.",
  84. "symfony/maker-bundle": "^1.14",
  85. "symfony/phpunit-bridge": "^5.4.",
  86. "symfony/stopwatch": "5.4.*",
  87. "symfony/web-profiler-bundle": "^5.4.",
  88. "ulrichsg/getopt-php": "*",
  89. "wp-cli/php-cli-tools": "^0.11.13",
  90. "codeception/module-asserts": "^1.0.0"
  91. },
  92. "config": {
  93. "preferred-install": {
  94. "*": "dist"
  95. },
  96. "sort-packages": true,
  97. "allow-plugins": {
  98. "composer/package-versions-deprecated": true,
  99. "symfony/flex": true,
  100. "wikimedia/composer-merge-plugin": true
  101. }
  102. },
  103. "autoload": {
  104. "files": [
  105. "src/Core/I18n/I18n.php"
  106. ],
  107. "psr-4": {
  108. "App\\": "src/",
  109. "Plugin\\": "plugins/",
  110. "Component\\": "components/"
  111. }
  112. },
  113. "autoload-dev": {
  114. "psr-4": {
  115. "App\\Tests\\": "tests/"
  116. }
  117. },
  118. "replace": {
  119. "paragonie/random_compat": "2.*",
  120. "symfony/polyfill-ctype": "*",
  121. "symfony/polyfill-iconv": "*",
  122. "symfony/polyfill-php72": "*",
  123. "symfony/polyfill-php71": "*",
  124. "symfony/polyfill-php70": "*",
  125. "symfony/polyfill-php56": "*"
  126. },
  127. "scripts": {
  128. "auto-scripts": {
  129. "cache:clear": "symfony-cmd",
  130. "assets:install %PUBLIC_DIR%": "symfony-cmd"
  131. },
  132. "post-install-cmd": [
  133. "@auto-scripts",
  134. "cp -fu bin/pre-commit .git/hooks"
  135. ],
  136. "post-update-cmd": [
  137. "@auto-scripts"
  138. ]
  139. },
  140. "conflict": {
  141. "symfony/symfony": "*"
  142. },
  143. "extra": {
  144. "symfony": {
  145. "allow-contrib": false,
  146. "require": "5.4.*"
  147. },
  148. "merge-plugin": {
  149. "include": [
  150. "components/*/composer.json",
  151. "plugins/*/composer.json"
  152. ]
  153. }
  154. },
  155. "repositories": [
  156. {
  157. "type": "package",
  158. "package": {
  159. "name": "niels-de-blaauw/php-doc-check",
  160. "version": "0.2.2",
  161. "bin": [
  162. "bin/php-doc-check"
  163. ],
  164. "autoload": {
  165. "psr-4": {
  166. "NdB\\PhpDocCheck\\": "src"
  167. }
  168. },
  169. "source": {
  170. "url": "https://github.com/someonewithpc/php-doc-check.git",
  171. "type": "git",
  172. "reference": "master"
  173. }
  174. }
  175. },
  176. {
  177. "type": "package",
  178. "package": {
  179. "name": "ulrichsg/getopt-php",
  180. "version": "4.0.0",
  181. "autoload": {
  182. "psr-4": {
  183. "GetOpt\\": "src"
  184. }
  185. },
  186. "source": {
  187. "url": "https://github.com/someonewithpc/getopt-php.git",
  188. "type": "git",
  189. "reference": "master"
  190. }
  191. }
  192. },
  193. {
  194. "type": "package",
  195. "package": {
  196. "name": "codeception/codeception",
  197. "version": "4.1.30",
  198. "autoload": {
  199. "psr-4": {
  200. "Codeception\\": "src/Codeception",
  201. "Codeception\\Extension\\": "ext"
  202. },
  203. "files": [
  204. "functions.php"
  205. ]
  206. },
  207. "require": {
  208. "php": ">=5.6.0 <9.0",
  209. "ext-curl": "*",
  210. "ext-json": "*",
  211. "ext-mbstring": "*",
  212. "codeception/lib-asserts": "^1.0 | 2.0.*@dev",
  213. "guzzlehttp/psr7": "^1.4 | ^2.0",
  214. "symfony/finder": ">=2.7 <6.0",
  215. "symfony/console": ">=2.7 <6.0",
  216. "symfony/event-dispatcher": ">=2.7 <6.0",
  217. "symfony/yaml": ">=2.7 <6.0",
  218. "symfony/css-selector": ">=2.7 <6.0",
  219. "behat/gherkin": "^4.4.0",
  220. "codeception/phpunit-wrapper": ">6.0.15 <6.1.0 | ^6.6.1 | ^7.7.1 | ^8.1.1 | ^9.0",
  221. "codeception/stub": "^2.0 | ^3.0 | ^4.0"
  222. },
  223. "bin": [
  224. "codecept"
  225. ],
  226. "source": {
  227. "url": "https://github.com/someonewithpc/Codeception.git",
  228. "type": "git",
  229. "reference": "4.1"
  230. }
  231. }
  232. }
  233. ]
  234. }